Patchwork [1/1] gnutls: Fix configure failure

login
register
mail settings
Submitter Zhai, Edwin
Date Oct. 8, 2011, 8:30 a.m.
Message ID <e315a66f8b76ba1c3282ed8907d276ba298050db.1318062305.git.edwin.zhai@intel.com>
Download mbox | patch
Permalink /patch/12957/
State New, archived
Headers show

Comments

Zhai, Edwin - Oct. 8, 2011, 8:30 a.m.
From: Zhai Edwin <edwin.zhai@intel.com>

gnutls fails in configure as depends on p11-kit after last upgrade. Removing
this dependency via configure option can fix following error:


| checking for fork... (cached) yes
| checking for P11_KIT... configure: error: Package requirements (p11-kit-1 >= 0.2) were not met:
|
| No package 'p11-kit-1' found
|
| Consider adjusting the PKG_CONFIG_PATH environment variable if you
| installed software in a non-standard prefix.
|
| Alternatively, you may set the environment variables P11_KIT_CFLAGS
| and P11_KIT_LIBS to avoid the need to call pkg-config.
| See the pkg-config man page for more details.
|
| ERROR: oe_runconf failed


Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
---
 meta/recipes-support/gnutls/gnutls.inc |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-support/gnutls/gnutls.inc b/meta/recipes-support/gnutls/gnutls.inc
index 9257880..8818c32 100644
--- a/meta/recipes-support/gnutls/gnutls.inc
+++ b/meta/recipes-support/gnutls/gnutls.inc
@@ -3,7 +3,7 @@  HOMEPAGE = "http://www.gnu.org/software/gnutls/"
 BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
 DEPENDS = "zlib lzo libtasn1 libgcrypt (>= 1.4.2) libcap"
 
-INC_PR = "r2"
+INC_PR = "r3"
 
 LICENSE = "GPLv3+ & LGPLv2.1+"
 LICENSE_${PN} = "LGPLv2.1+"
@@ -24,7 +24,7 @@  EXTRA_OECONF="--with-included-opencdk --with-included-libcfg --disable-rpath \
               --with-libgcrypt --with-libgcrypt-prefix=${STAGING_DIR_HOST}${prefix} \
               --with-libdl-prefix=${STAGING_DIR_HOST}${prefix} \
               --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
-              --with-lzo --disable-guile \
+              --with-lzo --disable-guile --without-p11-kit \
               "
 do_configure_prepend() {
 	for dir in . lib libextra; do