diff mbox series

[master/kirkstone,63/65] optee-os: Allow build to continue without TI_SECURE_DEV_PKG set

Message ID 20220913035541.2364351-64-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Latest 2022.09 sync-up with Dunfell #1 | expand

Commit Message

Denys Dmytriyenko Sept. 13, 2022, 3:55 a.m. UTC
From: Andrew Davis <afd@ti.com>

Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
index 5d50a04f..e268a542 100644
--- a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
+++ b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
@@ -41,7 +41,12 @@  optee_sign_legacyhs() {
 # Signing procedure for K3 HS devices
 optee_sign_k3hs() {
     ( cd ${B}/core/; \
-        ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh tee-pager_v2.bin tee-pager.bin.signed; \
+        if [ -f ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ]; then \
+            ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh tee-pager_v2.bin tee-pager.bin.signed; \
+        else \
+            echo "Warning: TI_SECURE_DEV_PKG not set, OP-TEE not signed."; \
+            cp tee-pager_v2.bin tee-pager.bin.signed; \
+        fi; \
         mv tee-pager.bin.signed ${B}/bl32.bin; \
         cp tee.elf ${B}/bl32.elf; \
     )