Patchwork libpam: add flex-native to DEPENDS

login
register
mail settings
Submitter Andrew Gabbasov
Date Sept. 28, 2011, 12:10 p.m.
Message ID <4E830EB6.3050004@mentor.com>
Download mbox | patch
Permalink /patch/12345/
State New, archived
Headers show

Comments

Andrew Gabbasov - Sept. 28, 2011, 12:10 p.m.
flex-native is required for building libpam. Although this dependency
is now fulfilled indirectly through bison recipe, having an explicit one
would be preferable.

Signed-off-by: Andrew Gabbasov <andrew_gabbasov@mentor.com>
---
 meta/recipes-extended/pam/libpam_1.1.4.bb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/recipes-extended/pam/libpam_1.1.4.bb b/meta/recipes-extended/pam/libpam_1.1.4.bb
index d6f95b1..868bffd 100644
--- a/meta/recipes-extended/pam/libpam_1.1.4.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.4.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
 
 PR = "r2"
 
-DEPENDS = "bison flex cracklib"
+DEPENDS = "bison flex flex-native cracklib"
 RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
 RDEPENDS_${PN}-xtests = "libpam pam-plugin-access pam-plugin-debug pam-plugin-cracklib pam-plugin-pwhistory \
                         pam-plugin-succeed-if pam-plugin-time coreutils"