[meta-python,3/5] python3-cmd2: Upgrade 2.3.0 -> 2.3.1

Message ID 20211119102740.2676-3-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-prompt-toolkit: Upgrade 3.0.21 -> 3.0.22 | expand

Commit Message

Leon Anavi Nov. 19, 2021, 10:27 a.m. UTC
Upgrade to release 2.3.1:

- Fixed issue introduced in 2.3.0 with AlternatingTable,
  BorderedTable, and SimpleTable that caused header alignment
  settings to be overridden by data alignment settings.
- CompletionItems now saves the original object from which it
  creates a string.
- Using CompletionItems as argparse choices is fully supported.
  cmd2 patched argparse to compare input to the original value
  instead of the CompletionItems instance.
- ArgparseCompleter now does the following if a list of
  CompletionItems was created with numerical types:
  * Sorts completion hints numerically
  * Right-aligns the left-most column in completion hint table

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/{python3-cmd2_2.3.0.bb => python3-cmd2_2.3.1.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-cmd2_2.3.0.bb => python3-cmd2_2.3.1.bb} (86%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cmd2_2.3.0.bb b/meta-python/recipes-devtools/python/python3-cmd2_2.3.1.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-cmd2_2.3.0.bb
rename to meta-python/recipes-devtools/python/python3-cmd2_2.3.1.bb
index 0cc8e9ce5..8167d2050 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_2.3.1.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
 
 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
 
-SRC_URI[sha256sum] = "2493ab8e5baab3d1a0325ea50920674a63de41bee4c63a634ac5cb42bfd63c1b"
+SRC_URI[sha256sum] = "44f9d93bbcd90c6dda70e73db722d6b27b551d98bef28bd82fd14ccbe88d18ea"
 
 inherit pypi setuptools3