Patchwork [1/1] libglade: fix the python environment settings

login
register
mail settings
Submitter Dongxiao Xu
Date Sept. 22, 2011, 2:51 a.m.
Message ID <683e143afdf821e4531850e2ae4c0dfd3e25798c.1316659695.git.dongxiao.xu@intel.com>
Download mbox | patch
Permalink /patch/11945/
State New, archived
Headers show

Comments

Dongxiao Xu - Sept. 22, 2011, 2:51 a.m.
@PYTHON@ will points to the abstract path in sysroot, which should be
replaced by "#!/usr/bin/env python".

This should fix the sato-sdk rootfs error.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
---
 .../libglade-2.6.4/python_environment.patch        |    9 +++++++++
 meta/recipes-gnome/libglade/libglade_2.6.4.bb      |    4 ++--
 2 files changed, 11 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
Saul Wold - Sept. 22, 2011, 3:05 a.m.
On 09/21/2011 07:51 PM, Dongxiao Xu wrote:
> @PYTHON@ will points to the abstract path in sysroot, which should be
> replaced by "#!/usr/bin/env python".
>
> This should fix the sato-sdk rootfs error.
>
> Signed-off-by: Dongxiao Xu<dongxiao.xu@intel.com>
> ---
>   .../libglade-2.6.4/python_environment.patch        |    9 +++++++++
>   meta/recipes-gnome/libglade/libglade_2.6.4.bb      |    4 ++--
>   2 files changed, 11 insertions(+), 2 deletions(-)
>   create mode 100644 meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
>
> diff --git a/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch b/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
> new file mode 100644
> index 0000000..6f2cc36
> --- /dev/null
> +++ b/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
This patch needs a patch header.

Sau!

> @@ -0,0 +1,9 @@
> +diff -ruN libglade-2.6.4-orig//libglade-convert.in libglade-2.6.4/libglade-convert.in
> +--- libglade-2.6.4-orig//libglade-convert.in	2011-09-22 10:18:28.991164003 +0800
> ++++ libglade-2.6.4/libglade-convert.in	2011-09-22 10:18:55.431164003 +0800
> +@@ -1,4 +1,4 @@
> +-#!@PYTHON@
> ++#!/usr/bin/env python
> + # -*- mode: python -*-
> +
> + # yes, this requires python 2.x and an XML parser module (eg. PyExpat)
> diff --git a/meta/recipes-gnome/libglade/libglade_2.6.4.bb b/meta/recipes-gnome/libglade/libglade_2.6.4.bb
> index d5b41f2..b0e0339 100644
> --- a/meta/recipes-gnome/libglade/libglade_2.6.4.bb
> +++ b/meta/recipes-gnome/libglade/libglade_2.6.4.bb
> @@ -8,12 +8,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605 \
>                       file://glade/glade-gtk.c;endline=22;md5=766f993433e2642fec87936d319990ff"
>
>   SECTION = "libs"
> -PR = "r0"
> +PR = "r1"
>   DEPENDS = "gtk+ gtk-doc-native"
>
>   inherit autotools pkgconfig gnome
>
> -SRC_URI += "file://glade-cruft.patch file://no-xml2.patch"
> +SRC_URI += "file://glade-cruft.patch file://no-xml2.patch file://python_environment.patch"
>
>   SRC_URI[archive.md5sum] = "d1776b40f4e166b5e9c107f1c8fe4139"
>   SRC_URI[archive.sha256sum] = "64361e7647839d36ed8336d992fd210d3e8139882269bed47dc4674980165dec"
Richard Purdie - Sept. 22, 2011, 3:54 a.m.
On Thu, 2011-09-22 at 10:51 +0800, Dongxiao Xu wrote:
> @PYTHON@ will points to the abstract path in sysroot, which should be
> replaced by "#!/usr/bin/env python".
> 
> This should fix the sato-sdk rootfs error.
> 
> Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>

Merged to master with a patch header added, thanks.

Richard

Patch

diff --git a/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch b/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
new file mode 100644
index 0000000..6f2cc36
--- /dev/null
+++ b/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
@@ -0,0 +1,9 @@ 
+diff -ruN libglade-2.6.4-orig//libglade-convert.in libglade-2.6.4/libglade-convert.in
+--- libglade-2.6.4-orig//libglade-convert.in	2011-09-22 10:18:28.991164003 +0800
++++ libglade-2.6.4/libglade-convert.in	2011-09-22 10:18:55.431164003 +0800
+@@ -1,4 +1,4 @@
+-#!@PYTHON@
++#!/usr/bin/env python
+ # -*- mode: python -*-
+ 
+ # yes, this requires python 2.x and an XML parser module (eg. PyExpat)
diff --git a/meta/recipes-gnome/libglade/libglade_2.6.4.bb b/meta/recipes-gnome/libglade/libglade_2.6.4.bb
index d5b41f2..b0e0339 100644
--- a/meta/recipes-gnome/libglade/libglade_2.6.4.bb
+++ b/meta/recipes-gnome/libglade/libglade_2.6.4.bb
@@ -8,12 +8,12 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605 \
                     file://glade/glade-gtk.c;endline=22;md5=766f993433e2642fec87936d319990ff"
 
 SECTION = "libs"
-PR = "r0"
+PR = "r1"
 DEPENDS = "gtk+ gtk-doc-native"
 
 inherit autotools pkgconfig gnome
 
-SRC_URI += "file://glade-cruft.patch file://no-xml2.patch"
+SRC_URI += "file://glade-cruft.patch file://no-xml2.patch file://python_environment.patch"
 
 SRC_URI[archive.md5sum] = "d1776b40f4e166b5e9c107f1c8fe4139"
 SRC_URI[archive.sha256sum] = "64361e7647839d36ed8336d992fd210d3e8139882269bed47dc4674980165dec"