diff mbox series

[meta-python] python3-pybind11: Update to Version 2.10.0.

Message ID 20220826140910.71664-1-philip@balister.org
State Under Review
Headers show
Series [meta-python] python3-pybind11: Update to Version 2.10.0. | expand

Commit Message

Philip Balister Aug. 26, 2022, 2:09 p.m. UTC
* Dropped patch for cross compile. 918d4481a4f69c7a4cbb4282acbabd28e2433039
   fixes this upstream.
 * This also fixing an issue building gnuradio where pybind looked for
   something in /usr/include/pythonX.Y on the build machine.

Signed-off-by: Philip Balister <philip@balister.org>
---
 ...ck-pointer-size-when-cross-compiling.patch | 31 -------------------
 ...11_2.9.2.bb => python3-pybind11_2.10.0.bb} |  4 +--
 2 files changed, 2 insertions(+), 33 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-check-pointer-size-when-cross-compiling.patch
 rename meta-python/recipes-devtools/python/{python3-pybind11_2.9.2.bb => python3-pybind11_2.10.0.bb} (85%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-check-pointer-size-when-cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-check-pointer-size-when-cross-compiling.patch
deleted file mode 100644
index 761422e07..000000000
--- a/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-check-pointer-size-when-cross-compiling.patch
+++ /dev/null
@@ -1,31 +0,0 @@ 
-From 2e9318f7a70699eed239aee6301d1d0bbd2457ee Mon Sep 17 00:00:00 2001
-From: Philip Balister <philip@balister.org>
-Date: Fri, 10 Jul 2020 10:14:59 -0400
-Subject: [PATCH] Do not check pointer size when cross compiling.
-
-It is reasonable to build for 32 machine on a 64 bit build machine. Prevents:
-| CMake Error at tools/FindPythonLibsNew.cmake:127 (message):
-|   Python config failure: Python is 64-bit, chosen compiler is 32-bit
-
-Signed-off-by: Philip Balister <philip@balister.org>
-Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
----
- tools/FindPythonLibsNew.cmake | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/FindPythonLibsNew.cmake b/tools/FindPythonLibsNew.cmake
-index 3605aebc..67f4d4a0 100644
---- a/tools/FindPythonLibsNew.cmake
-+++ b/tools/FindPythonLibsNew.cmake
-@@ -156,7 +156,7 @@ list(GET _PYTHON_VALUES 9 PYTHON_MULTIARCH)
- 
- # Make sure the Python has the same pointer-size as the chosen compiler
- # Skip if CMAKE_SIZEOF_VOID_P is not defined
--if(CMAKE_SIZEOF_VOID_P AND (NOT "${PYTHON_SIZEOF_VOID_P}" STREQUAL "${CMAKE_SIZEOF_VOID_P}"))
-+if((NOT CMAKE_CROSSCOMPILING) AND CMAKE_SIZEOF_VOID_P AND (NOT "${PYTHON_SIZEOF_VOID_P}" STREQUAL "${CMAKE_SIZEOF_VOID_P}"))
-   if(PythonLibsNew_FIND_REQUIRED)
-     math(EXPR _PYTHON_BITS "${PYTHON_SIZEOF_VOID_P} * 8")
-     math(EXPR _CMAKE_BITS "${CMAKE_SIZEOF_VOID_P} * 8")
--- 
-2.17.1
-
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
similarity index 85%
rename from meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb
rename to meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
index 433bfd60e..66aefac3d 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
@@ -7,9 +7,9 @@  DEPENDS = "boost"
 
 SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
            file://0001-Do-not-strip-binaries.patch \
-           file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
 "
-SRCREV = "914c06fb252b6cc3727d0eedab6736e88a3fcb01"
+
+SRCREV = "aa304c9c7d725ffb9d10af08a3b34cb372307020"
 
 S = "${WORKDIR}/git"