Patchwork qt4: update to latest version 4.7.4

login
register
mail settings
Submitter Eric BENARD
Date Sept. 21, 2011, 12:52 p.m.
Message ID <4E79DE1D.5000303@eukrea.com>
Download mbox | patch
Permalink /patch/11881/
State New, archived
Headers show

Comments

Eric BENARD - Sept. 21, 2011, 12:52 p.m.
Hi Koen,

Le 21/09/2011 12:44, Koen Kooi a écrit :
> Op 20 sep. 2011, om 23:18 heeft Eric Bénard het volgende geschreven:
>> ok 2 branches are available here : git://github.com/eukrea/oe-core.git
>> - qt4_improve for improvement to existing qt 4.7.3,
>> - qt4_upgrade for adding qt 4.7.4 (with DEFAULT_PREFERENCE=-1 as suggested by Koen.
>>
>> Please test them so that we can fix potential failures and send the pull request (I have compile test actually running with the latest changes in qt4_upgrade branch so this one is not yet fully tested).
>
> I'm building the qt4_upgrade branch + http://patches.openembedded.org/patch/11289/ + PREFERRED_VERSION change in angstrom. If you don't hear anything the test went OK :)

in angstrom you also need to add :
+PREFERRED_VERSION_qt4-native = "${ANGSTROM_QT_VERSION}"
else qt4-native 4.7.3 will be used.

Eric
Koen Kooi - Sept. 21, 2011, 1:05 p.m.
Op 21 sep. 2011, om 14:52 heeft Eric Bénard het volgende geschreven:

> Hi Koen,
> 
> Le 21/09/2011 12:44, Koen Kooi a écrit :
>> Op 20 sep. 2011, om 23:18 heeft Eric Bénard het volgende geschreven:
>>> ok 2 branches are available here : git://github.com/eukrea/oe-core.git
>>> - qt4_improve for improvement to existing qt 4.7.3,
>>> - qt4_upgrade for adding qt 4.7.4 (with DEFAULT_PREFERENCE=-1 as suggested by Koen.
>>> 
>>> Please test them so that we can fix potential failures and send the pull request (I have compile test actually running with the latest changes in qt4_upgrade branch so this one is not yet fully tested).
>> 
>> I'm building the qt4_upgrade branch + http://patches.openembedded.org/patch/11289/ + PREFERRED_VERSION change in angstrom. If you don't hear anything the test went OK :)
> 
> in angstrom you also need to add :
> +PREFERRED_VERSION_qt4-native = "${ANGSTROM_QT_VERSION}"
> else qt4-native 4.7.3 will be used.

I already have that :)

So far the only bug with 4.7.4 is this:

WARNING: For recipe qt4-x11-free, the following files were installed but not shipped in any package:
WARNING:   /usr/share/qt4/phrasebooks/swedish.qph
WARNING:   /usr/share/qt4/phrasebooks/dutch.qph
WARNING:   /usr/share/qt4/phrasebooks/german.qph
WARNING:   /usr/share/qt4/phrasebooks/polish.qph
WARNING:   /usr/share/qt4/phrasebooks/danish.qph
WARNING:   /usr/share/qt4/phrasebooks/japanese.qph
WARNING:   /usr/share/qt4/phrasebooks/finnish.qph
WARNING:   /usr/share/qt4/phrasebooks/norwegian.qph
WARNING:   /usr/share/qt4/phrasebooks/french.qph
WARNING:   /usr/share/qt4/phrasebooks/russian.qph
WARNING:   /usr/share/qt4/phrasebooks/spanish.qph
WARNING:   /usr/share/qt4/phrasebooks/hungarian.qph
WARNING:   /usr/share/qt4/phrasebooks/italian.qph
WARNING:   /usr/lib/.debug/libQtSql.so
WARNING:   /usr/lib/.debug/libQtNetwork.so
WARNING:   /usr/lib/.debug/libQtTest.so
WARNING:   /usr/lib/.debug/libQtXml.so
WARNING:   /usr/lib/.debug/libQtDesignerComponents.so
WARNING:   /usr/lib/.debug/libQtXmlPatterns.so
WARNING:   /usr/lib/.debug/libQtCLucene.so
WARNING:   /usr/lib/.debug/libphonon.so
WARNING:   /usr/lib/.debug/libQtSvg.so
WARNING:   /usr/lib/.debug/libQtMultimedia.so
WARNING:   /usr/lib/.debug/libQtDBus.so
WARNING:   /usr/lib/.debug/libQtScriptTools.so
WARNING:   /usr/lib/.debug/libQtDeclarative.so
WARNING:   /usr/lib/.debug/libQtCore.so
WARNING:   /usr/lib/.debug/libQtWebKit.so
WARNING:   /usr/lib/.debug/libQtDesigner.so
WARNING:   /usr/lib/.debug/libQtGui.so
WARNING:   /usr/lib/.debug/libQt3Support.so
WARNING:   /usr/lib/.debug/libQtHelp.so
WARNING:   /usr/lib/.debug/libQtScript.so
WARNING:   /usr/lib/fonts/fontdir
WARNING:   /usr/lib/qt4/plugins/qmltooling/.debug/libqmldbg_tcp.so
Eric BENARD - Sept. 21, 2011, 1:16 p.m.
Le 21/09/2011 15:05, Koen Kooi a écrit :
> WARNING: For recipe qt4-x11-free, the following files were installed but not shipped in any package:
> WARNING:   /usr/share/qt4/phrasebooks/swedish.qph
> WARNING:   /usr/share/qt4/phrasebooks/dutch.qph
> WARNING:   /usr/share/qt4/phrasebooks/german.qph
> WARNING:   /usr/share/qt4/phrasebooks/polish.qph
> WARNING:   /usr/share/qt4/phrasebooks/danish.qph
> WARNING:   /usr/share/qt4/phrasebooks/japanese.qph
> WARNING:   /usr/share/qt4/phrasebooks/finnish.qph
> WARNING:   /usr/share/qt4/phrasebooks/norwegian.qph
> WARNING:   /usr/share/qt4/phrasebooks/french.qph
> WARNING:   /usr/share/qt4/phrasebooks/russian.qph
> WARNING:   /usr/share/qt4/phrasebooks/spanish.qph
> WARNING:   /usr/share/qt4/phrasebooks/hungarian.qph
> WARNING:   /usr/share/qt4/phrasebooks/italian.qph

OK I forget to integrate Otavio's patch which fix the translations. I'll 
update tonight.

Eric
Paul Eggleton - Sept. 28, 2011, 10:11 a.m.
Hi Eric,

On Wednesday 21 September 2011 14:16:25 Eric Bénard wrote:
> Le 21/09/2011 15:05, Koen Kooi a écrit :
> > WARNING: For recipe qt4-x11-free, the following files were installed but
> > not shipped in any package:
> > WARNING:   /usr/share/qt4/phrasebooks/swedish.qph
> > WARNING:   /usr/share/qt4/phrasebooks/dutch.qph
> > WARNING:   /usr/share/qt4/phrasebooks/german.qph
> > WARNING:   /usr/share/qt4/phrasebooks/polish.qph
> > WARNING:   /usr/share/qt4/phrasebooks/danish.qph
> > WARNING:   /usr/share/qt4/phrasebooks/japanese.qph
> > WARNING:   /usr/share/qt4/phrasebooks/finnish.qph
> > WARNING:   /usr/share/qt4/phrasebooks/norwegian.qph
> > WARNING:   /usr/share/qt4/phrasebooks/french.qph
> > WARNING:   /usr/share/qt4/phrasebooks/russian.qph
> > WARNING:   /usr/share/qt4/phrasebooks/spanish.qph
> > WARNING:   /usr/share/qt4/phrasebooks/hungarian.qph
> > WARNING:   /usr/share/qt4/phrasebooks/italian.qph
> 
> OK I forget to integrate Otavio's patch which fix the translations. I'll 
> update tonight.

Did you have a chance to do this? I don't see an additional commit in the 
qt4_upgrade branch in your repo.

Cheers,
Paul
Eric BENARD - Sept. 28, 2011, 10:23 a.m.
Hi Paul,

Le 28/09/2011 12:11, Paul Eggleton a écrit :
> On Wednesday 21 September 2011 14:16:25 Eric Bénard wrote:
>> Le 21/09/2011 15:05, Koen Kooi a écrit :
>>> WARNING: For recipe qt4-x11-free, the following files were installed but
>>> not shipped in any package:
>>> WARNING:   /usr/share/qt4/phrasebooks/swedish.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/dutch.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/german.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/polish.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/danish.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/japanese.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/finnish.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/norwegian.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/french.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/russian.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/spanish.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/hungarian.qph
>>> WARNING:   /usr/share/qt4/phrasebooks/italian.qph
>>
>> OK I forget to integrate Otavio's patch which fix the translations. I'll
>> update tonight.
>
> Did you have a chance to do this? I don't see an additional commit in the
> qt4_upgrade branch in your repo.
>
I have the patch locally and I will (really) work on this tonight.
Sorry for the delay I've been overbusy since last wednesday.

Eric
Otavio Salvador - Sept. 28, 2011, 1:11 p.m.
On Wed, Sep 28, 2011 at 07:23, Eric Bénard <eric@eukrea.com> wrote:
> I have the patch locally and I will (really) work on this tonight.
> Sorry for the delay I've been overbusy since last wednesday.

Now that this is going into master, I think we ought to update it
directly instead of adding the newer version.
Richard Purdie - Sept. 28, 2011, 1:33 p.m.
On Wed, 2011-09-28 at 10:11 -0300, Otavio Salvador wrote:
> On Wed, Sep 28, 2011 at 07:23, Eric Bénard <eric@eukrea.com> wrote:
> > I have the patch locally and I will (really) work on this tonight.
> > Sorry for the delay I've been overbusy since last wednesday.
> 
> Now that this is going into master, I think we ought to update it
> directly instead of adding the newer version.

What we'll do is add the new version, someone will tell me when meta-oe
is updated and then we'll remove the old one. 

There are a few other pieces I think need to transition out of OE-Core
at this point:

eglibc 2.12
gcc 4.5
gnome-vfs

so if we could move them over to meta-oe at the same time I think that
would be good. If the gcc 4.5 over there already is fine, we can just
remove the OE-Core version. 

Any help in sorting this out would be appreciated as the patch backlog
and release are taking up a lot of my time atm.

Cheers,

Richard
Eric BENARD - Sept. 30, 2011, 11:47 a.m.
Hi Paul,

I've updated and tested the branches by rebasing on current oe-core and
integrating Otavio's patch concerning the translations :
https://github.com/eukrea/oe-core/tree/qt4_improve
https://github.com/eukrea/oe-core/tree/qt4_upgrade

Is that OK for you or should I rework something ?

Eric
Paul Eggleton - Sept. 30, 2011, 4:23 p.m.
On Friday 30 September 2011 12:47:05 you wrote:
> I've updated and tested the branches by rebasing on current oe-core and
> integrating Otavio's patch concerning the translations :
> https://github.com/eukrea/oe-core/tree/qt4_improve
> https://github.com/eukrea/oe-core/tree/qt4_upgrade
> 
> Is that OK for you or should I rework something ?

Looks pretty good. Richard has asked me to send a pull request for these with 
any comments attached so I'm about to do that now.

BTW thanks for bringing these together and especially for the SDK fix in 
particular, very keen to see that merged.

Cheers,
Paul

Patch

diff --git a/conf/distro/include/angstrom-2010-preferred-versions.inc b/conf/dis
index 2fee7f1..8bbdb4d 100644
--- a/conf/distro/include/angstrom-2010-preferred-versions.inc
+++ b/conf/distro/include/angstrom-2010-preferred-versions.inc
@@ -1,5 +1,5 @@ 
  ANGSTROM_MESA_VERSION = "7.10.2"
-ANGSTROM_QT_VERSION ?= "4.7.3"
+ANGSTROM_QT_VERSION ?= "4.7.4"
  ANGSTROM_LIBTOOL_VERSION = "2.4"
  # Use new sysroot feature
  LIBTOOL_HAS_SYSROOT = "yes"
@@ -49,6 +49,7 @@  PREFERRED_VERSION_pkgconfig   = "0.25"
  PREFERRED_VERSION_pkgconfig-native = "0.25"
  PREFERRED_VERSION_pulseaudio   = "0.9.23"
  PREFERRED_VERSION_python-pycairo = "1.8.0"
+PREFERRED_VERSION_qt4-native = "${ANGSTROM_QT_VERSION}"
  PREFERRED_VERSION_qt4-tools-native = "${ANGSTROM_QT_VERSION}"
  PREFERRED_VERSION_qt4-tools-sdk = "${ANGSTROM_QT_VERSION}"
  PREFERRED_VERSION_qt4-embedded = "${ANGSTROM_QT_VERSION}"