Patchwork [0/1,v2] Fix avahi x11 dependency with non-GPLv3 Build

login
register
mail settings
Submitter Saul Wold
Date Sept. 20, 2011, 6:26 p.m.
Message ID <cover.1316542962.git.sgw@linux.intel.com>
Download mbox
Permalink /patch/11741/
State New, archived
Headers show

Pull-request

git://git.yoctoproject.org/poky-contrib sgw/oe-fix

Comments

Saul Wold - Sept. 20, 2011, 6:26 p.m.
This version removes the DISTRO_FEATURE check for x11 and simply
removes the DEPENDS on gtk and sets --disable-gtk to EXTRA_OECONF.

If someone uses/needs the avahi-ui bits, they are available in the
OE repo, we would consider taking them into oe-core if there is a clear
need for it.

Sau!


The following changes since commit 81274f4488fbc4d68d150870735ec0181b60b451:

  freetype: disable bzip2 compressed font support (2011-09-19 13:14:03 +0100)

are available in the git repository at:
  git://git.yoctoproject.org/poky-contrib sgw/oe-fix
  http://git.yoctoproject.org/cgit.cgi/poky-contrib/log/?h=sgw/oe-fix

Saul Wold (1):
  avahi: remove avahi-ui related packages

 meta/recipes-connectivity/avahi/avahi.inc |   19 +++++++------------
 1 files changed, 7 insertions(+), 12 deletions(-)
Koen Kooi - Sept. 20, 2011, 6:49 p.m.
Op 20 sep. 2011, om 20:26 heeft Saul Wold het volgende geschreven:

> This version removes the DISTRO_FEATURE check for x11 and simply
> removes the DEPENDS on gtk and sets --disable-gtk to EXTRA_OECONF.
> 
> If someone uses/needs the avahi-ui bits, they are available in the
> OE repo, we would consider taking them into oe-core if there is a clear
> need for it.

Can't you just port over the OE classic recipe instead of this half-baked patch?