diff mbox series

[v4,1/1] mdio-tools: add recipes

Message ID 20220822054431.3856258-1-potin.lai@quantatw.com
State Under Review
Headers show
Series [v4,1/1] mdio-tools: add recipes | expand

Commit Message

Potin Lai Aug. 22, 2022, 5:44 a.m. UTC
From: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>

Self-description from the README: mdio-tools is a low-level debug tool
for communicating with devices attached to an MDIO bus.

Signed-off-by: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
---
LINK: [v3] https://lore.kernel.org/all/20220608163628.5745-1-potin.lai.pt@gmail.com/
LINK: [v2] https://lore.kernel.org/all/20220201142608.186135-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
LINK: [v1] https://lore.kernel.org/all/20220107150722.2221609-1-enguerrand.de-ribaucourt@savoirfairelinux.com/

change v3 --> v4:
* update license to follow SPDX format
* mdio configs update and merged in yocto-kernel-cache
  LINK: https://git.yoctoproject.org/yocto-kernel-cache/commit/?h=yocto-5.15&id=0d58e2d6a7824df62129af91bbe9fadfdb5f9dce
  tested on yocto-kernel-cache commit: f7f709bf874f85baff9f2fb0ac0341c08399b144

change v1 --> v2:
change v2 --> v3:
* update version to 1.1.1

change v1 --> v2:
* moved in recipes-support
* removed version in mdio-tools_1.0.1.inc filename
---
 .../recipes-support/mdio-tools/mdio-netlink_git.bb  | 13 +++++++++++++
 .../recipes-support/mdio-tools/mdio-tools.inc       |  9 +++++++++
 .../recipes-support/mdio-tools/mdio-tools_git.bb    |  9 +++++++++
 3 files changed, 31 insertions(+)
 create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
 create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools.inc
 create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
new file mode 100644
index 000000000..b50d33f90
--- /dev/null
+++ b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
@@ -0,0 +1,13 @@ 
+require mdio-tools.inc
+
+DEPENDS += "virtual/kernel libmnl"
+# This module requires Linux 5.6 higher
+
+S = "${WORKDIR}/git/kernel"
+
+inherit module
+
+EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
+MODULES_INSTALL_TARGET = "install"
+
+RPROVIDES:${PN} += "kernel-module-mdio-netlink"
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools.inc b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
new file mode 100644
index 000000000..a8a435fad
--- /dev/null
+++ b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
@@ -0,0 +1,9 @@ 
+DESCRIPTION = "A low-level debug tool for communicating with devices attached to an MDIO bus"
+SECTION = "networking"
+HOMEPAGE = "https://github.com/wkz/mdio-tools"
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/wkz/mdio-tools.git;protocol=https;branch=master"
+SRCREV = "07cbff2d5e2de05037e5e7edd5044d678394c8d1"
+PV = "1.1.1"
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
new file mode 100644
index 000000000..cd4df3da0
--- /dev/null
+++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
@@ -0,0 +1,9 @@ 
+require mdio-tools.inc
+
+DEPENDS += "libmnl"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools
+
+RDEPENDS:${PN} = "kernel-module-mdio-netlink"