diff mbox series

[v2,6/6] xmlto: Update to use upstream tip of trunk

Message ID 20220816033005.2700801-6-raj.khem@gmail.com
State Accepted, archived
Commit 27a5000724e4f4df274279bcd801d1dc2830208e
Headers show
Series [1/6] time: Add missing include for memset | expand

Commit Message

Khem Raj Aug. 16, 2022, 3:30 a.m. UTC
There are several fixes which are done to fix builds with newer
compilers after 0.0.28 was releases in 2015 a long time ago.

Add a patch to fix manpages builds not trying to access network during
build

Regenerate xmlif from lex files, before configuring the build

Add UPSTREAM_CHECK_COMMITS = "1"

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2:
- Update patch status
- Add UPSTREAM_CHECK_COMMITS

 .../0001-Skip-validating-xmlto-output.patch   | 29 +++++++++++++++++++
 ...rop-the-test-of-xmllint-and-xsltproc.patch |  6 ++--
 meta/recipes-devtools/xmlto/xmlto_0.0.28.bb   | 16 +++++++---
 3 files changed, 44 insertions(+), 7 deletions(-)
 create mode 100644 meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
 rename meta/recipes-devtools/xmlto/{xmlto-0.0.28 => xmlto}/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch (91%)

Comments

Richard Purdie Aug. 17, 2022, 2:31 p.m. UTC | #1
On Mon, 2022-08-15 at 20:30 -0700, Khem Raj wrote:
> There are several fixes which are done to fix builds with newer
> compilers after 0.0.28 was releases in 2015 a long time ago.
> 
> Add a patch to fix manpages builds not trying to access network during
> build
> 
> Regenerate xmlif from lex files, before configuring the build
> 
> Add UPSTREAM_CHECK_COMMITS = "1"
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
> v2:
> - Update patch status
> - Add UPSTREAM_CHECK_COMMITS
> 
>  .../0001-Skip-validating-xmlto-output.patch   | 29 +++++++++++++++++++
>  ...rop-the-test-of-xmllint-and-xsltproc.patch |  6 ++--
>  meta/recipes-devtools/xmlto/xmlto_0.0.28.bb   | 16 +++++++---
>  3 files changed, 44 insertions(+), 7 deletions(-)
>  create mode 100644 meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
>  rename meta/recipes-devtools/xmlto/{xmlto-0.0.28 => xmlto}/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch (91%)
> 
> diff --git a/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch b/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
> new file mode 100644
> index 00000000000..c6857a9da51
> --- /dev/null
> +++ b/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
> @@ -0,0 +1,29 @@
> +From 3deb7a0eded04ab08a9cb2d88526cb1c7b440061 Mon Sep 17 00:00:00 2001
> +From: Khem Raj <raj.khem@gmail.com>
> +Date: Sun, 14 Aug 2022 00:23:29 -0700
> +Subject: [PATCH] Skip validating xmlto output
> +
> +Avoids network access
> +
> +Upstream-Status: Submitted [https://pagure.io/xmlto/pull-request/11]
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +---
> + Makefile.am | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/Makefile.am b/Makefile.am
> +index 50fa279..6a2da62 100644
> +--- a/Makefile.am
> ++++ b/Makefile.am
> +@@ -68,7 +68,7 @@ EXTRA_DIST = xmlto.spec \
> + 	doc/xmlif.xml \
> + 	xmlto.mak
> + 
> +-GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto -o $(@D) man $<
> ++GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto --skip-validation -o $(@D) man $<
> + man/man1/xmlto.1: doc/xmlto.xml ; $(GEN_MANPAGE)
> + man/man1/xmlif.1: doc/xmlif.xml ; $(GEN_MANPAGE)
> + 
> +-- 
> +2.37.2
> +
> diff --git a/meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch b/meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> similarity index 91%
> rename from meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> rename to meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> index 6d547a6c994..7cc3cbe0fb2 100644
> --- a/meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> +++ b/meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> @@ -9,9 +9,9 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
>   configure.in | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
>  
> -diff --git a/configure.in b/configure.in
> ---- a/configure.in
> -+++ b/configure.in
> +diff --git a/configure.ac b/configure.ac
> +--- a/configure.ac
> ++++ b/configure.ac
>  @@ -42,10 +42,10 @@ AC_ARG_VAR([LOCALE], [Name and path of the `locale' program.])
>   AC_PATH_PROG([LOCALE], [locale], [locale])
>   
> diff --git a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
> index 5cb9a4c57be..1913dd2833d 100644
> --- a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
> +++ b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
> @@ -6,17 +6,21 @@ LICENSE = "GPL-2.0-only"
>  
>  LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
>  
> -SRC_URI = "https://releases.pagure.org/xmlto/xmlto-${PV}.tar.gz \
> +SRCREV = "6fa6a0e07644f20abf2596f78a60112713e11cbe"
> +UPSTREAM_CHECK_COMMITS = "1"
> +SRC_URI = "git://pagure.io/xmlto.git;protocol=https;branch=master \
>             file://configure.in-drop-the-test-of-xmllint-and-xsltproc.patch \
> +           file://0001-Skip-validating-xmlto-output.patch \
>  "
> -SRC_URI[md5sum] = "a1fefad9d83499a15576768f60f847c6"
> -SRC_URI[sha256sum] = "2f986b7c9a0e9ac6728147668e776d405465284e13c74d4146c9cbc51fd8aad3"
> +S = "${WORKDIR}/git"
> +
> +PV .= "+0.0.29+git${SRCPV}"
>  
>  inherit autotools
>  
>  CLEANBROKEN = "1"
>  
> -DEPENDS = "libxml2-native"
> +DEPENDS = "libxml2-native libxslt-native flex-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
>  
>  RDEPENDS:${PN} = "docbook-xml-dtd4 \
>                    docbook-xsl-stylesheets \
> @@ -36,6 +40,10 @@ BBCLASSEXTEND = "native"
>  
>  EXTRA_OECONF:append = " BASH=/bin/bash GCP=/bin/cp XMLLINT=xmllint XSLTPROC=xsltproc"
>  
> +do_configure:prepend() {
> +    flex -o ${S}/xmlif/xmlif.c ${S}/xmlif/xmlif.l
> +}
> +
>  do_install:append:class-native() {
>      create_wrapper ${D}${bindir}/xmlto XML_CATALOG_FILES=${sysconfdir}/xml/catalog
>  }
> 

Seems to have a reproducibility problem:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/1401

Cheers,

Richard
Richard Purdie Aug. 17, 2022, 2:38 p.m. UTC | #2
On Wed, 2022-08-17 at 15:31 +0100, Richard Purdie via
lists.openembedded.org wrote:
> On Mon, 2022-08-15 at 20:30 -0700, Khem Raj wrote:
> > There are several fixes which are done to fix builds with newer
> > compilers after 0.0.28 was releases in 2015 a long time ago.
> > 
> > Add a patch to fix manpages builds not trying to access network during
> > build
> > 
> > Regenerate xmlif from lex files, before configuring the build
> > 
> > Add UPSTREAM_CHECK_COMMITS = "1"
> > 
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> > v2:
> > - Update patch status
> > - Add UPSTREAM_CHECK_COMMITS
> > 
> >  .../0001-Skip-validating-xmlto-output.patch   | 29 +++++++++++++++++++
> >  ...rop-the-test-of-xmllint-and-xsltproc.patch |  6 ++--
> >  meta/recipes-devtools/xmlto/xmlto_0.0.28.bb   | 16 +++++++---
> >  3 files changed, 44 insertions(+), 7 deletions(-)
> >  create mode 100644 meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
> >  rename meta/recipes-devtools/xmlto/{xmlto-0.0.28 => xmlto}/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch (91%)
> > 
> > diff --git a/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch b/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
> > new file mode 100644
> > index 00000000000..c6857a9da51
> > --- /dev/null
> > +++ b/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
> > @@ -0,0 +1,29 @@
> > +From 3deb7a0eded04ab08a9cb2d88526cb1c7b440061 Mon Sep 17 00:00:00 2001
> > +From: Khem Raj <raj.khem@gmail.com>
> > +Date: Sun, 14 Aug 2022 00:23:29 -0700
> > +Subject: [PATCH] Skip validating xmlto output
> > +
> > +Avoids network access
> > +
> > +Upstream-Status: Submitted [https://pagure.io/xmlto/pull-request/11]
> > +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > +---
> > + Makefile.am | 2 +-
> > + 1 file changed, 1 insertion(+), 1 deletion(-)
> > +
> > +diff --git a/Makefile.am b/Makefile.am
> > +index 50fa279..6a2da62 100644
> > +--- a/Makefile.am
> > ++++ b/Makefile.am
> > +@@ -68,7 +68,7 @@ EXTRA_DIST = xmlto.spec \
> > + 	doc/xmlif.xml \
> > + 	xmlto.mak
> > + 
> > +-GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto -o $(@D) man $<
> > ++GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto --skip-validation -o $(@D) man $<
> > + man/man1/xmlto.1: doc/xmlto.xml ; $(GEN_MANPAGE)
> > + man/man1/xmlif.1: doc/xmlif.xml ; $(GEN_MANPAGE)
> > + 
> > +-- 
> > +2.37.2
> > +
> > diff --git a/meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch b/meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> > similarity index 91%
> > rename from meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> > rename to meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> > index 6d547a6c994..7cc3cbe0fb2 100644
> > --- a/meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> > +++ b/meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
> > @@ -9,9 +9,9 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
> >   configure.in | 4 ++--
> >   1 file changed, 2 insertions(+), 2 deletions(-)
> >  
> > -diff --git a/configure.in b/configure.in
> > ---- a/configure.in
> > -+++ b/configure.in
> > +diff --git a/configure.ac b/configure.ac
> > +--- a/configure.ac
> > ++++ b/configure.ac
> >  @@ -42,10 +42,10 @@ AC_ARG_VAR([LOCALE], [Name and path of the `locale' program.])
> >   AC_PATH_PROG([LOCALE], [locale], [locale])
> >   
> > diff --git a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
> > index 5cb9a4c57be..1913dd2833d 100644
> > --- a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
> > +++ b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
> > @@ -6,17 +6,21 @@ LICENSE = "GPL-2.0-only"
> >  
> >  LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
> >  
> > -SRC_URI = "https://releases.pagure.org/xmlto/xmlto-${PV}.tar.gz \
> > +SRCREV = "6fa6a0e07644f20abf2596f78a60112713e11cbe"
> > +UPSTREAM_CHECK_COMMITS = "1"
> > +SRC_URI = "git://pagure.io/xmlto.git;protocol=https;branch=master \
> >             file://configure.in-drop-the-test-of-xmllint-and-xsltproc.patch \
> > +           file://0001-Skip-validating-xmlto-output.patch \
> >  "
> > -SRC_URI[md5sum] = "a1fefad9d83499a15576768f60f847c6"
> > -SRC_URI[sha256sum] = "2f986b7c9a0e9ac6728147668e776d405465284e13c74d4146c9cbc51fd8aad3"
> > +S = "${WORKDIR}/git"
> > +
> > +PV .= "+0.0.29+git${SRCPV}"
> >  
> >  inherit autotools
> >  
> >  CLEANBROKEN = "1"
> >  
> > -DEPENDS = "libxml2-native"
> > +DEPENDS = "libxml2-native libxslt-native flex-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
> >  
> >  RDEPENDS:${PN} = "docbook-xml-dtd4 \
> >                    docbook-xsl-stylesheets \
> > @@ -36,6 +40,10 @@ BBCLASSEXTEND = "native"
> >  
> >  EXTRA_OECONF:append = " BASH=/bin/bash GCP=/bin/cp XMLLINT=xmllint XSLTPROC=xsltproc"
> >  
> > +do_configure:prepend() {
> > +    flex -o ${S}/xmlif/xmlif.c ${S}/xmlif/xmlif.l
> > +}
> > +
> >  do_install:append:class-native() {
> >      create_wrapper ${D}${bindir}/xmlto XML_CATALOG_FILES=${sysconfdir}/xml/catalog
> >  }
> > 
> 
> Seems to have a reproducibility problem:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/1401
> 

and a packaging warning:

https://autobuilder.yoctoproject.org/typhoon/#/builders/40/builds/5723
https://autobuilder.yoctoproject.org/typhoon/#/builders/108/builds/3390

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch b/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
new file mode 100644
index 00000000000..c6857a9da51
--- /dev/null
+++ b/meta/recipes-devtools/xmlto/xmlto/0001-Skip-validating-xmlto-output.patch
@@ -0,0 +1,29 @@ 
+From 3deb7a0eded04ab08a9cb2d88526cb1c7b440061 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 14 Aug 2022 00:23:29 -0700
+Subject: [PATCH] Skip validating xmlto output
+
+Avoids network access
+
+Upstream-Status: Submitted [https://pagure.io/xmlto/pull-request/11]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 50fa279..6a2da62 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -68,7 +68,7 @@ EXTRA_DIST = xmlto.spec \
+ 	doc/xmlif.xml \
+ 	xmlto.mak
+ 
+-GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto -o $(@D) man $<
++GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto --skip-validation -o $(@D) man $<
+ man/man1/xmlto.1: doc/xmlto.xml ; $(GEN_MANPAGE)
+ man/man1/xmlif.1: doc/xmlif.xml ; $(GEN_MANPAGE)
+ 
+-- 
+2.37.2
+
diff --git a/meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch b/meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
similarity index 91%
rename from meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
rename to meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
index 6d547a6c994..7cc3cbe0fb2 100644
--- a/meta/recipes-devtools/xmlto/xmlto-0.0.28/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
+++ b/meta/recipes-devtools/xmlto/xmlto/configure.in-drop-the-test-of-xmllint-and-xsltproc.patch
@@ -9,9 +9,9 @@  Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  configure.in | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)
 
-diff --git a/configure.in b/configure.in
---- a/configure.in
-+++ b/configure.in
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
 @@ -42,10 +42,10 @@ AC_ARG_VAR([LOCALE], [Name and path of the `locale' program.])
  AC_PATH_PROG([LOCALE], [locale], [locale])
  
diff --git a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
index 5cb9a4c57be..1913dd2833d 100644
--- a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
+++ b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
@@ -6,17 +6,21 @@  LICENSE = "GPL-2.0-only"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 
-SRC_URI = "https://releases.pagure.org/xmlto/xmlto-${PV}.tar.gz \
+SRCREV = "6fa6a0e07644f20abf2596f78a60112713e11cbe"
+UPSTREAM_CHECK_COMMITS = "1"
+SRC_URI = "git://pagure.io/xmlto.git;protocol=https;branch=master \
            file://configure.in-drop-the-test-of-xmllint-and-xsltproc.patch \
+           file://0001-Skip-validating-xmlto-output.patch \
 "
-SRC_URI[md5sum] = "a1fefad9d83499a15576768f60f847c6"
-SRC_URI[sha256sum] = "2f986b7c9a0e9ac6728147668e776d405465284e13c74d4146c9cbc51fd8aad3"
+S = "${WORKDIR}/git"
+
+PV .= "+0.0.29+git${SRCPV}"
 
 inherit autotools
 
 CLEANBROKEN = "1"
 
-DEPENDS = "libxml2-native"
+DEPENDS = "libxml2-native libxslt-native flex-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
 
 RDEPENDS:${PN} = "docbook-xml-dtd4 \
                   docbook-xsl-stylesheets \
@@ -36,6 +40,10 @@  BBCLASSEXTEND = "native"
 
 EXTRA_OECONF:append = " BASH=/bin/bash GCP=/bin/cp XMLLINT=xmllint XSLTPROC=xsltproc"
 
+do_configure:prepend() {
+    flex -o ${S}/xmlif/xmlif.c ${S}/xmlif/xmlif.l
+}
+
 do_install:append:class-native() {
     create_wrapper ${D}${bindir}/xmlto XML_CATALOG_FILES=${sysconfdir}/xml/catalog
 }