diff mbox series

glibc: Bump to latest 2.36 branch

Message ID 20220812192725.2600254-1-raj.khem@gmail.com
State Accepted, archived
Commit e6ca788c180816f81f4f4271caf4f78e9ce6bbcc
Headers show
Series glibc: Bump to latest 2.36 branch | expand

Commit Message

Khem Raj Aug. 12, 2022, 7:27 p.m. UTC
Drop upstreamed patches

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/glibc/glibc-version.inc     |  2 +-
 ...define-STRCPY-guard-in-strcpy-sse2.S.patch | 28 ----------------
 ...ace-strcpy-call-with-memcpy-BZ-29454.patch | 32 -------------------
 meta/recipes-core/glibc/glibc_2.36.bb         |  2 --
 4 files changed, 1 insertion(+), 63 deletions(-)
 delete mode 100644 meta/recipes-core/glibc/glibc/0026-x86-Fix-define-STRCPY-guard-in-strcpy-sse2.S.patch
 delete mode 100644 meta/recipes-core/glibc/glibc/0027-elf-Replace-strcpy-call-with-memcpy-BZ-29454.patch
diff mbox series

Patch

diff --git a/meta/recipes-core/glibc/glibc-version.inc b/meta/recipes-core/glibc/glibc-version.inc
index f6cdbbf2414..74b48b05f48 100644
--- a/meta/recipes-core/glibc/glibc-version.inc
+++ b/meta/recipes-core/glibc/glibc-version.inc
@@ -1,6 +1,6 @@ 
 SRCBRANCH ?= "release/2.36/master"
 PV = "2.36"
-SRCREV_glibc ?= "ac47d8f6cf9744139adb12f540fb9cc610cac579"
+SRCREV_glibc ?= "302bc33bc53c787da6e74162a7092e9c0fb964a8"
 SRCREV_localedef ?= "794da69788cbf9bf57b59a852f9f11307663fa87"
 
 GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
diff --git a/meta/recipes-core/glibc/glibc/0026-x86-Fix-define-STRCPY-guard-in-strcpy-sse2.S.patch b/meta/recipes-core/glibc/glibc/0026-x86-Fix-define-STRCPY-guard-in-strcpy-sse2.S.patch
deleted file mode 100644
index 2caff3a0d53..00000000000
--- a/meta/recipes-core/glibc/glibc/0026-x86-Fix-define-STRCPY-guard-in-strcpy-sse2.S.patch
+++ /dev/null
@@ -1,28 +0,0 @@ 
-From 1d4d09d9dff96f46674262534ce1f0e51a8252cb Mon Sep 17 00:00:00 2001
-From: Noah Goldstein <goldstein.w.n@gmail.com>
-Date: Sun, 7 Aug 2022 22:42:30 +0800
-Subject: [PATCH] x86: Fix `#define STRCPY` guard in strcpy-sse2.S
-
-`#ifndef STPCPY` is incorrect for checking if `STRCPY` is already
-defined.  It doesn't end up mattering as the whole check is
-guarded by `#if IS_IN (libc)` but is incorrect none the less.
-
-Upstream-Status: Backport [https://sourceware.org/git/?p=glibc.git;a=commit;h=312ded0d6339e8c463d0395397b5825401b14f54]
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- sysdeps/x86_64/multiarch/strcpy-sse2.S | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sysdeps/x86_64/multiarch/strcpy-sse2.S b/sysdeps/x86_64/multiarch/strcpy-sse2.S
-index e29b411314..d6b9bae5f8 100644
---- a/sysdeps/x86_64/multiarch/strcpy-sse2.S
-+++ b/sysdeps/x86_64/multiarch/strcpy-sse2.S
-@@ -22,7 +22,7 @@
- 
- # include <sysdep.h>
- 
--# ifndef STPCPY
-+# ifndef STRCPY
- #  define STRCPY __strcpy_sse2
- # endif
- 
diff --git a/meta/recipes-core/glibc/glibc/0027-elf-Replace-strcpy-call-with-memcpy-BZ-29454.patch b/meta/recipes-core/glibc/glibc/0027-elf-Replace-strcpy-call-with-memcpy-BZ-29454.patch
deleted file mode 100644
index a2c951ad936..00000000000
--- a/meta/recipes-core/glibc/glibc/0027-elf-Replace-strcpy-call-with-memcpy-BZ-29454.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From f0e36cf0b348dbc990af9f869196710ca89c28c2 Mon Sep 17 00:00:00 2001
-From: Noah Goldstein <goldstein.w.n@gmail.com>
-Date: Sun, 7 Aug 2022 23:54:19 +0800
-Subject: [PATCH] elf: Replace `strcpy` call with `memcpy` [BZ #29454]
-
-GCC normally does this optimization for us in
-strlen_pass::handle_builtin_strcpy but only for optimized
-build. To avoid needing to include strcpy.S in the rtld build to
-support the debug build, just do the optimization by hand.
-
-Upstream-Status: Backport [https://sourceware.org/git/?p=glibc.git;a=commit;h=483cfe1a6a33d6335b1901581b41040d2d412511]
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- elf/dl-cache.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/elf/dl-cache.c b/elf/dl-cache.c
-index c02a95d9b5..03a6d236e8 100644
---- a/elf/dl-cache.c
-+++ b/elf/dl-cache.c
-@@ -513,8 +513,9 @@ _dl_load_cache_lookup (const char *name)
-      we are accessing. Therefore we must make the copy of the
-      mapping data without using malloc.  */
-   char *temp;
--  temp = alloca (strlen (best) + 1);
--  strcpy (temp, best);
-+  size_t best_len = strlen (best) + 1;
-+  temp = alloca (best_len);
-+  memcpy (temp, best, best_len);
-   return __strdup (temp);
- }
- 
diff --git a/meta/recipes-core/glibc/glibc_2.36.bb b/meta/recipes-core/glibc/glibc_2.36.bb
index 2db3994cf7b..6ccb392f090 100644
--- a/meta/recipes-core/glibc/glibc_2.36.bb
+++ b/meta/recipes-core/glibc/glibc_2.36.bb
@@ -51,8 +51,6 @@  SRC_URI =  "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
            file://0023-fix-create-thread-failed-in-unprivileged-process-BZ-.patch \
            file://0024-Avoid-hardcoded-build-time-paths-in-the-output-binar.patch \
            file://0025-Revert-Linux-Implement-a-useful-version-of-_startup_.patch \
-           file://0026-x86-Fix-define-STRCPY-guard-in-strcpy-sse2.S.patch \
-           file://0027-elf-Replace-strcpy-call-with-memcpy-BZ-29454.patch \
 "
 S = "${WORKDIR}/git"
 B = "${WORKDIR}/build-${TARGET_SYS}"