diff mbox series

[2/2] perl: Pass additional flags to enable lfs and gnu source

Message ID 20220809054120.820562-2-raj.khem@gmail.com
State Accepted, archived
Commit 322b0a7f7a2e2c6a459deca6de0052365b1c1727
Headers show
Series [1/2] perl-cross: Correct function signatures in configure_func.sh | expand

Commit Message

Khem Raj Aug. 9, 2022, 5:41 a.m. UTC
These defines are needed to enable some GNU APIs and large file support
is default in OE anyway

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/perl/perl_5.36.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/perl/perl_5.36.0.bb b/meta/recipes-devtools/perl/perl_5.36.0.bb
index 4456cdbcfba..ead7dace165 100644
--- a/meta/recipes-devtools/perl/perl_5.36.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.36.0.bb
@@ -45,6 +45,8 @@  PACKAGECONFIG[gdbm] = ",-Ui_gdbm,gdbm"
 # Don't generate comments in enc2xs output files. They are not reproducible
 export ENC2XS_NO_COMMENTS = "1"
 
+CFLAGS += "-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+
 do_configure:prepend() {
     cp -rfp ${STAGING_DATADIR_NATIVE}/perl-cross/* ${S}
 }