Patchwork [meta-handheld,08/12] linux.inc: drop old udev check

login
register
mail settings
Submitter lumag
Date Sept. 7, 2011, 2:03 p.m.
Message ID <1315404187-18176-9-git-send-email-dbaryshkov@gmail.com>
Download mbox | patch
Permalink /patch/11165/
State Accepted, archived
Headers show

Comments

lumag - Sept. 7, 2011, 2:03 p.m.
We have udev 145, 164, 173 in oe-core/meta-oe and the check was
for udev < 141.

Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
---
 recipes-kernel/linux/linux.inc |   39 +++++++++++++++------------------------
 1 files changed, 15 insertions(+), 24 deletions(-)

Patch

diff --git a/recipes-kernel/linux/linux.inc b/recipes-kernel/linux/linux.inc
index 51231db..03b9811 100644
--- a/recipes-kernel/linux/linux.inc
+++ b/recipes-kernel/linux/linux.inc
@@ -9,9 +9,6 @@  inherit kernel siteinfo
 # Enable OABI compat for people stuck with obsolete userspace
 ARM_KEEP_OABI ?= "1"
 
-# Quirk for udev greater or equal 141
-UDEV_GE_141 ?= "0"
-
 # Set the verbosity of kernel messages during runtime
 # You can define CMDLINE_DEBUG in your local.conf or distro.conf to override this behaviour
 CMDLINE_DEBUG ?= '${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "loglevel=3", d)}'
@@ -87,13 +84,8 @@  do_configure_prepend() {
         echo 'CONFIG_LOCALVERSION="${LOCALVERSION}"' >>${S}/.config
         echo '# CONFIG_LOCALVERSION_AUTO is not set' >>${S}/.config
 
-        #
-        # Udev quirks
-        #
-
         # Newer versions of udev mandate that sysfs doesn't have deprecated entries
-        if [ "${UDEV_GE_141}" = "1" ] ; then
-            sed -e /CONFIG_SYSFS_DEPRECATED/d \
+        sed -e /CONFIG_SYSFS_DEPRECATED/d \
                 -e /CONFIG_SYSFS_DEPRECATED_V2/d \
                 -e /CONFIG_HOTPLUG/d \
                 -e /CONFIG_UEVENT_HELPER_PATH/d \
@@ -107,21 +99,20 @@  do_configure_prepend() {
                 -e /CONFIG_BLK_DEV_BSG/d \
                 -i '${S}/.config'
 
-            echo '# CONFIG_SYSFS_DEPRECATED is not set' >> ${S}/.config
-            echo '# CONFIG_SYSFS_DEPRECATED_V2 is not set' >> ${S}/.config
-            echo 'CONFIG_HOTPLUG=y' >> ${S}/.config
-            echo 'CONFIG_UEVENT_HELPER_PATH=""' >> ${S}/.config
-            echo 'CONFIG_UNIX=y' >> ${S}/.config
-            echo 'CONFIG_SYSFS=y' >> ${S}/.config
-            echo 'CONFIG_PROC_FS=y' >> ${S}/.config
-            echo 'CONFIG_TMPFS=y' >> ${S}/.config
-            echo 'CONFIG_INOTIFY_USER=y' >> ${S}/.config
-            echo 'CONFIG_SIGNALFD=y' >> ${S}/.config
-            echo 'CONFIG_TMPFS_POSIX_ACL=y' >> ${S}/.config
-            echo 'CONFIG_BLK_DEV_BSG=y' >> ${S}/.config
-            echo 'CONFIG_DEVTMPFS=y' >> ${S}/.config
-            echo 'CONFIG_DEVTMPFS_MOUNT=y' >> ${S}/.config
-        fi
+        echo '# CONFIG_SYSFS_DEPRECATED is not set' >> ${S}/.config
+        echo '# CONFIG_SYSFS_DEPRECATED_V2 is not set' >> ${S}/.config
+        echo 'CONFIG_HOTPLUG=y' >> ${S}/.config
+        echo 'CONFIG_UEVENT_HELPER_PATH=""' >> ${S}/.config
+        echo 'CONFIG_UNIX=y' >> ${S}/.config
+        echo 'CONFIG_SYSFS=y' >> ${S}/.config
+        echo 'CONFIG_PROC_FS=y' >> ${S}/.config
+        echo 'CONFIG_TMPFS=y' >> ${S}/.config
+        echo 'CONFIG_INOTIFY_USER=y' >> ${S}/.config
+        echo 'CONFIG_SIGNALFD=y' >> ${S}/.config
+        echo 'CONFIG_TMPFS_POSIX_ACL=y' >> ${S}/.config
+        echo 'CONFIG_BLK_DEV_BSG=y' >> ${S}/.config
+        echo 'CONFIG_DEVTMPFS=y' >> ${S}/.config
+        echo 'CONFIG_DEVTMPFS_MOUNT=y' >> ${S}/.config
 
         # Newer inits like systemd need cgroup support
         if [ "${KERNEL_ENABLE_CGROUPS}" = "1" ] ; then