Patchwork [meta-oe,v3,1/1] python-lxml: Add version 2.2.8 (initial recipe)

login
register
mail settings
Submitter Noor Ahsan
Date Sept. 6, 2011, 12:17 p.m.
Message ID <63593868972de9f2c78299efac4d5e77889f23df.1315311355.git.noor_ahsan@mentor.com>
Download mbox | patch
Permalink /patch/11045/
State New, archived
Headers show

Comments

Noor Ahsan - Sept. 6, 2011, 12:17 p.m.
From: Noor Ahsan <noor_ahsan@mentor.com>

* Imported from oe.dev commit id bc6a94559157e6fcc190a22a259c0f757b8664ae.
* Getting "skipping incompatible libraries" message in compilation log. Fixed that issue by changing --with-xml2-config=${STAGING_BINDIR_NATIVE}/xml2-config to --with-xml2-config=${STAGING_BINDIR_CROSS}/xml2-config.
* Added BBCLASSEXTEND native and nativesdk for native recipe.
* Tested with MACHINE = 'qemuppc'

Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Reviewed-by: Paul Menzel <paulepanter@users.sourceforge.net>
---
 .../recipes-devtools/python/python-lxml_2.2.8.bb   |   33 ++++++++++++++++++++
 1 files changed, 33 insertions(+), 0 deletions(-)
 create mode 100644 meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb

Patch

diff --git a/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb b/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb
new file mode 100644
index 0000000..e19c776
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb
@@ -0,0 +1,33 @@ 
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=7de92baeb3b7bfaebe72404155fdb346"
+SRCNAME = "lxml"
+
+DEPENDS = "libxml2 libxslt"
+RDEPENDS_${PN} += "libxml2 libxslt python-compression"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
+SRC_URI[lxml.md5sum] = "d6c612d63a84d79440912a1b29d3b981"
+SRC_URI[lxml.sha256sum] = "89b73925b5e3295dcf4675cb948007a20eb029fe35c9a162ae19ec11f1abafe5"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DISTUTILS_BUILD_ARGS += " \
+                     --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+                     --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+                     --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+                     --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native"
+
+
+