diff mbox series

[meta-ti,dunfell,3/8] trusted-firmware-a: Allow build to continue without TI_SECURE_DEV_PKG set

Message ID 20220805024934.23349-3-afd@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell,1/8] u-boot-ti: Do not prepend output files with DEPLOYDIR | expand

Commit Message

Andrew Davis Aug. 5, 2022, 2:49 a.m. UTC
Signed-off-by: Andrew Davis <afd@ti.com>
---
 .../trusted-firmware-a_%.bbappend             | 38 ++++++++-----------
 1 file changed, 16 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 9645137e..965c99d4 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -9,42 +9,36 @@  TFA_SPD_k3 = "opteed"
 EXTRA_OEMAKE_append_k3 = "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
 EXTRA_OEMAKE_append_k3 = "${@ 'K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"
 
-do_compile_append_am65xx-hs-evm() {
+# Signing procedure for K3 HS devices
+tfa_sign_k3hs() {
 	export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
 	( cd ${B}/${BUILD_DIR}/release/; \
 		mv bl31.bin bl31.bin.unsigned; \
-		${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+		if [ -f ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ]; then \
+			${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+		else \
+			echo "Warning: TI_SECURE_DEV_PKG not set, TF-A not signed."; \
+			cp bl31.bin.unsigned bl31.bin; \
+		fi; \
 	)
 }
 
+do_compile_append_am65xx-hs-evm() {
+	tfa_sign_k3hs
+}
+
 do_compile_append_am64xx-hs-evm() {
-        export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
-        ( cd ${B}/${BUILD_DIR}/release/; \
-                mv bl31.bin bl31.bin.unsigned; \
-                ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
-        )
+	tfa_sign_k3hs
 }
 
 do_compile_append_j7-hs-evm() {
-	export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
-	( cd ${B}/${BUILD_DIR}/release/; \
-		mv bl31.bin bl31.bin.unsigned; \
-		${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
-	)
+	tfa_sign_k3hs
 }
 
 do_compile_append_j7200-hs-evm() {
-        export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
-        ( cd ${B}/${BUILD_DIR}/release/; \
-                mv bl31.bin bl31.bin.unsigned; \
-                ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
-        )
+	tfa_sign_k3hs
 }
 
 do_compile_append_j721s2-hs-evm() {
-	export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
-	( cd ${B}/${BUILD_DIR}/release/; \
-		mv bl31.bin bl31.bin.unsigned; \
-		${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
-	)
+	tfa_sign_k3hs
 }