diff mbox series

[meta-oe] Add python-requests-unixsocket recipe

Message ID 20220802225217.2804578-1-edtanous@google.com
State New
Headers show
Series [meta-oe] Add python-requests-unixsocket recipe | expand

Commit Message

edtanous@google.com Aug. 2, 2022, 10:52 p.m. UTC
From: Ed Tanous <edtanous@google.com>

From the pypi description:
Use requests to talk HTTP via a UNIX domain socket

Signed-off-by: Ed Tanous <edtanous@google.com>
---
 .../python/python3-requests-unixsocket_0.3.0.bb    | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-requests-unixsocket_0.3.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-requests-unixsocket_0.3.0.bb b/meta-python/recipes-devtools/python/python3-requests-unixsocket_0.3.0.bb
new file mode 100644
index 000000000..330ab7c06
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests-unixsocket_0.3.0.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Use requests to talk HTTP via a UNIX domain socket"
+HOMEPAGE = "https://pypi.org/project/requests-unixsocket/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[sha256sum] = "28304283ea9357d45fff58ad5b11e47708cfbf5806817aa59b2a363228ee971e"
+
+PYPI_PACKAGE = "requests-unixsocket"
+
+inherit pypi
+inherit setuptools3
+
+DEPENDS += "python3-pbr-native"
+RDEPENDS_${PN} = "python3-requests python3-urllib3"