diff mbox series

[meta-networking] sshpass: add recipe

Message ID 20220727181928.34114-1-mike.petersen@ni.com
State New
Headers show
Series [meta-networking] sshpass: add recipe | expand

Commit Message

Mike Petersen July 27, 2022, 6:19 p.m. UTC
From: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>

Needed for automating ssh logins, used in auto-tests.

Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Signed-off-by: Mike Petersen <mike.petersen@ni.com>
---
 .../recipes-connectivity/sshpass/sshpass.inc           | 10 ++++++++++
 .../recipes-connectivity/sshpass/sshpass_1.05.bb       |  8 ++++++++
 2 files changed, 18 insertions(+)
 create mode 100644 meta-networking/recipes-connectivity/sshpass/sshpass.inc
 create mode 100644 meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb

Comments

akuster808 July 27, 2022, 8:19 p.m. UTC | #1
On 7/27/22 11:19, Mike Petersen wrote:
> From: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
>
> Needed for automating ssh logins, used in auto-tests.
>
> Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
> Signed-off-by: Mike Petersen <mike.petersen@ni.com>
> ---
>   .../recipes-connectivity/sshpass/sshpass.inc           | 10 ++++++++++
>   .../recipes-connectivity/sshpass/sshpass_1.05.bb       |  8 ++++++++
>   2 files changed, 18 insertions(+)
>   create mode 100644 meta-networking/recipes-connectivity/sshpass/sshpass.inc
>   create mode 100644 meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
>
> diff --git a/meta-networking/recipes-connectivity/sshpass/sshpass.inc b/meta-networking/recipes-connectivity/sshpass/sshpass.inc
> new file mode 100644
> index 000000000..b19ae4313
> --- /dev/null
> +++ b/meta-networking/recipes-connectivity/sshpass/sshpass.inc
> @@ -0,0 +1,10 @@
> +DESCRIPTION = "Non-interactive ssh password auth"
> +HOMEPAGE = "http://sshpass.sourceforge.net/"
> +SECTION = "console/network"
> +LICENSE = "GPLv2"
> +
> +SRC_URI = "${SOURCEFORGE_MIRROR}/sshpass/sshpass-${PV}.tar.gz"
> +
> +INC_PR = "r0"
> +
> +inherit autotools
> diff --git a/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb b/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
> new file mode 100644
> index 000000000..a345dbd95
> --- /dev/null
> +++ b/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
> @@ -0,0 +1,8 @@
> +PR = "${INC_PR}.0"
> +
Don't think we need PR.
> +require sshpass.inc

Can we combine both files?
> +
> +LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
> +
> +SRC_URI[md5sum] = "c52d65fdee0712af6f77eb2b60974ac7"
> +SRC_URI[sha256sum] = "c3f78752a68a0c3f62efb3332cceea0c8a1f04f7cf6b46e00ec0c3000bc8483e"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#98018): https://lists.openembedded.org/g/openembedded-devel/message/98018
> Mute This Topic: https://lists.openembedded.org/mt/92655179/3616698
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj July 27, 2022, 9:25 p.m. UTC | #2
There are newer version in some layers on layerindex e.g.

https://layers.openembedded.org/layerindex/recipe/106509/

perhaps use that as starting point.


On 7/27/22 2:19 PM, Mike Petersen wrote:
> From: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
> 
> Needed for automating ssh logins, used in auto-tests.
> 
> Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
> Signed-off-by: Mike Petersen <mike.petersen@ni.com>
> ---
>   .../recipes-connectivity/sshpass/sshpass.inc           | 10 ++++++++++
>   .../recipes-connectivity/sshpass/sshpass_1.05.bb       |  8 ++++++++
>   2 files changed, 18 insertions(+)
>   create mode 100644 meta-networking/recipes-connectivity/sshpass/sshpass.inc
>   create mode 100644 meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
> 
> diff --git a/meta-networking/recipes-connectivity/sshpass/sshpass.inc b/meta-networking/recipes-connectivity/sshpass/sshpass.inc
> new file mode 100644
> index 000000000..b19ae4313
> --- /dev/null
> +++ b/meta-networking/recipes-connectivity/sshpass/sshpass.inc
> @@ -0,0 +1,10 @@
> +DESCRIPTION = "Non-interactive ssh password auth"
> +HOMEPAGE = "http://sshpass.sourceforge.net/"
> +SECTION = "console/network"
> +LICENSE = "GPLv2"
> +
> +SRC_URI = "${SOURCEFORGE_MIRROR}/sshpass/sshpass-${PV}.tar.gz"
> +
> +INC_PR = "r0"
> +
> +inherit autotools
> diff --git a/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb b/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
> new file mode 100644
> index 000000000..a345dbd95
> --- /dev/null
> +++ b/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
> @@ -0,0 +1,8 @@
> +PR = "${INC_PR}.0"
> +
> +require sshpass.inc
> +
> +LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
> +
> +SRC_URI[md5sum] = "c52d65fdee0712af6f77eb2b60974ac7"
> +SRC_URI[sha256sum] = "c3f78752a68a0c3f62efb3332cceea0c8a1f04f7cf6b46e00ec0c3000bc8483e"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#98018): https://lists.openembedded.org/g/openembedded-devel/message/98018
> Mute This Topic: https://lists.openembedded.org/mt/92655179/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-networking/recipes-connectivity/sshpass/sshpass.inc b/meta-networking/recipes-connectivity/sshpass/sshpass.inc
new file mode 100644
index 000000000..b19ae4313
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sshpass/sshpass.inc
@@ -0,0 +1,10 @@ 
+DESCRIPTION = "Non-interactive ssh password auth"
+HOMEPAGE = "http://sshpass.sourceforge.net/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sshpass/sshpass-${PV}.tar.gz"
+
+INC_PR = "r0"
+
+inherit autotools
diff --git a/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb b/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
new file mode 100644
index 000000000..a345dbd95
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sshpass/sshpass_1.05.bb
@@ -0,0 +1,8 @@ 
+PR = "${INC_PR}.0"
+
+require sshpass.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+SRC_URI[md5sum] = "c52d65fdee0712af6f77eb2b60974ac7"
+SRC_URI[sha256sum] = "c3f78752a68a0c3f62efb3332cceea0c8a1f04f7cf6b46e00ec0c3000bc8483e"