diff mbox series

[kirkstone,master] apt: fix do_package_qa failure

Message ID 20220727053939.353717-1-changqing.li@windriver.com
State New, archived
Headers show
Series [kirkstone,master] apt: fix do_package_qa failure | expand

Commit Message

Changqing Li July 27, 2022, 5:39 a.m. UTC
From: Changqing Li <changqing.li@windriver.com>

bitbake nativesdk-apt failed with error:
ERROR: nativesdk-apt-2.4.5-r0 do_package_qa: QA Issue: nativesdk-apt installs files in /usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-pokysdk-linux/var/volatile, but it is expected to be empty [empty-dirs]

Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
 meta/recipes-devtools/apt/apt_2.4.5.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Alexander Kanavin July 27, 2022, 11:51 a.m. UTC | #1
What is actually being installed in there? Is it really right to remove it?

Alex

On Wed, 27 Jul 2022 at 07:39, Changqing Li <changqing.li@windriver.com> wrote:
>
> From: Changqing Li <changqing.li@windriver.com>
>
> bitbake nativesdk-apt failed with error:
> ERROR: nativesdk-apt-2.4.5-r0 do_package_qa: QA Issue: nativesdk-apt installs files in /usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-pokysdk-linux/var/volatile, but it is expected to be empty [empty-dirs]
>
> Signed-off-by: Changqing Li <changqing.li@windriver.com>
> ---
>  meta/recipes-devtools/apt/apt_2.4.5.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-devtools/apt/apt_2.4.5.bb b/meta/recipes-devtools/apt/apt_2.4.5.bb
> index 1d94dd118c..d79a33857a 100644
> --- a/meta/recipes-devtools/apt/apt_2.4.5.bb
> +++ b/meta/recipes-devtools/apt/apt_2.4.5.bb
> @@ -123,6 +123,7 @@ do_install:append:class-native() {
>
>  do_install:append:class-nativesdk() {
>         customize_apt_conf_sample
> +       rm -rf ${D}${localstatedir}/log
>  }
>
>  do_install:append:class-target() {
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#168542): https://lists.openembedded.org/g/openembedded-core/message/168542
> Mute This Topic: https://lists.openembedded.org/mt/92643987/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Changqing Li July 28, 2022, 3:53 a.m. UTC | #2
On 7/27/22 19:51, Alexander Kanavin wrote:
> [Please note: This e-mail is from an EXTERNAL e-mail address]
>
> What is actually being installed in there? Is it really right to remove it?

An empty dir apt is installed under /var/log/. It should be ok to remove 
it since apt could create it when it doesn't exist.

We have remove it for target. So I do the same for nativesdk. Another 
solution could be INSANE_SKIP the empty-dirs.

How do you think?

Changqing

>
> Alex
>
> On Wed, 27 Jul 2022 at 07:39, Changqing Li <changqing.li@windriver.com> wrote:
>> From: Changqing Li <changqing.li@windriver.com>
>>
>> bitbake nativesdk-apt failed with error:
>> ERROR: nativesdk-apt-2.4.5-r0 do_package_qa: QA Issue: nativesdk-apt installs files in /usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-pokysdk-linux/var/volatile, but it is expected to be empty [empty-dirs]
>>
>> Signed-off-by: Changqing Li <changqing.li@windriver.com>
>> ---
>>   meta/recipes-devtools/apt/apt_2.4.5.bb | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/meta/recipes-devtools/apt/apt_2.4.5.bb b/meta/recipes-devtools/apt/apt_2.4.5.bb
>> index 1d94dd118c..d79a33857a 100644
>> --- a/meta/recipes-devtools/apt/apt_2.4.5.bb
>> +++ b/meta/recipes-devtools/apt/apt_2.4.5.bb
>> @@ -123,6 +123,7 @@ do_install:append:class-native() {
>>
>>   do_install:append:class-nativesdk() {
>>          customize_apt_conf_sample
>> +       rm -rf ${D}${localstatedir}/log
>>   }
>>
>>   do_install:append:class-target() {
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#168542): https://lists.openembedded.org/g/openembedded-core/message/168542
>> Mute This Topic: https://lists.openembedded.org/mt/92643987/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Alexander Kanavin July 28, 2022, 7:05 a.m. UTC | #3
On Thu, 28 Jul 2022 at 05:53, Changqing Li <changqing.li@windriver.com> wrote:
> An empty dir apt is installed under /var/log/. It should be ok to remove
> it since apt could create it when it doesn't exist.
>
> We have remove it for target. So I do the same for nativesdk. Another
> solution could be INSANE_SKIP the empty-dirs.
>
> How do you think?

That is fine, but please resend with this information in the commit message.

Alex
diff mbox series

Patch

diff --git a/meta/recipes-devtools/apt/apt_2.4.5.bb b/meta/recipes-devtools/apt/apt_2.4.5.bb
index 1d94dd118c..d79a33857a 100644
--- a/meta/recipes-devtools/apt/apt_2.4.5.bb
+++ b/meta/recipes-devtools/apt/apt_2.4.5.bb
@@ -123,6 +123,7 @@  do_install:append:class-native() {
 
 do_install:append:class-nativesdk() {
 	customize_apt_conf_sample
+	rm -rf ${D}${localstatedir}/log
 }
 
 do_install:append:class-target() {