diff mbox series

[meta-python] Add runtime dependencies for python3-supervisor

Message ID 9b5881cf-15b1-b401-c6bd-5f9232fd0d4c@gmx.net
State New
Headers show
Series [meta-python] Add runtime dependencies for python3-supervisor | expand

Commit Message

Martin Großhauser July 22, 2022, 7:39 p.m. UTC
Running supervisord without these fails with import errors. smtpd might look strange, but provides required asynchat.py.
---
  .../recipes-devtools/python/python3-supervisor_4.2.4.bb      | 5 +++++
  1 file changed, 5 insertions(+)

--
2.25.1

Comments

Jan Vermaete July 24, 2022, 7:31 p.m. UTC | #1
Hi,

Could it be it should be '${PYTHON_PN}-setuptools-native'
iso  '${PYTHON_PN}-setuptools' ?

Br

On Fri, Jul 22, 2022 at 9:39 PM Martin Großhauser <mgrosshauser@gmx.net>
wrote:

> Running supervisord without these fails with import errors. smtpd might
> look strange, but provides required asynchat.py.
> ---
>   .../recipes-devtools/python/python3-supervisor_4.2.4.bb      | 5 +++++
>   1 file changed, 5 insertions(+)
>
> diff --git a/meta-python/recipes-devtools/python/
> python3-supervisor_4.2.4.bb b/meta-python/recipes-devtools/python/
> python3-supervisor_4.2.4.bb
> index fdd8a76cf..7da29e39b 100644
> --- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
> +++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
> @@ -13,6 +13,11 @@ PYPI_PACKAGE = "supervisor"
>   inherit pypi systemd setuptools3
>   RDEPENDS:${PN} = "\
>       ${PYTHON_PN}-meld3 \
> +    ${PYTHON_PN}-io \
> +    ${PYTHON_PN}-xmlrpc \
> +    ${PYTHON_PN}-resource \
> +    ${PYTHON_PN}-setuptools \
> +    ${PYTHON_PN}-smtpd \
>   "
>
>   SRC_URI += "file://supervisord.conf \
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97956):
> https://lists.openembedded.org/g/openembedded-devel/message/97956
> Mute This Topic: https://lists.openembedded.org/mt/92555239/2167232
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> jan.vermaete@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj July 25, 2022, 2 a.m. UTC | #2
On Sun, Jul 24, 2022 at 3:31 PM Jan Vermaete <jan.vermaete@gmail.com> wrote:
>
> Hi,
>
> Could it be it should be '${PYTHON_PN}-setuptools-native' iso  '${PYTHON_PN}-setuptools' ?

rdep on a native package wont be a good thing.
>
> Br
>
> On Fri, Jul 22, 2022 at 9:39 PM Martin Großhauser <mgrosshauser@gmx.net> wrote:
>>
>> Running supervisord without these fails with import errors. smtpd might look strange, but provides required asynchat.py.
>> ---
>>   .../recipes-devtools/python/python3-supervisor_4.2.4.bb      | 5 +++++
>>   1 file changed, 5 insertions(+)
>>
>> diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
>> index fdd8a76cf..7da29e39b 100644
>> --- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
>> +++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
>> @@ -13,6 +13,11 @@ PYPI_PACKAGE = "supervisor"
>>   inherit pypi systemd setuptools3
>>   RDEPENDS:${PN} = "\
>>       ${PYTHON_PN}-meld3 \
>> +    ${PYTHON_PN}-io \
>> +    ${PYTHON_PN}-xmlrpc \
>> +    ${PYTHON_PN}-resource \
>> +    ${PYTHON_PN}-setuptools \
>> +    ${PYTHON_PN}-smtpd \
>>   "
>>
>>   SRC_URI += "file://supervisord.conf \
>> --
>> 2.25.1
>>
>>
>>
>>
>
>
> --
> Jan Vermaete
> “Success is a self-correcting phenomenom.” -- Gary Hamel
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97963): https://lists.openembedded.org/g/openembedded-devel/message/97963
> Mute This Topic: https://lists.openembedded.org/mt/92555239/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tim Orling July 25, 2022, 3:21 a.m. UTC | #3
On Sun, Jul 24, 2022 at 7:01 PM Khem Raj <raj.khem@gmail.com> wrote:

> On Sun, Jul 24, 2022 at 3:31 PM Jan Vermaete <jan.vermaete@gmail.com>
> wrote:
> >
> > Hi,
> >
> > Could it be it should be '${PYTHON_PN}-setuptools-native' iso
> '${PYTHON_PN}-setuptools' ?
>
> rdep on a native package wont be a good thing.
> >
> > Br
> >
> > On Fri, Jul 22, 2022 at 9:39 PM Martin Großhauser <mgrosshauser@gmx.net>
> wrote:
> >>
> >> Running supervisord without these fails with import errors. smtpd might
> look strange, but provides required asynchat.py.
> >> ---
> >>   .../recipes-devtools/python/python3-supervisor_4.2.4.bb      | 5
> +++++
> >>   1 file changed, 5 insertions(+)
> >>
> >> diff --git a/meta-python/recipes-devtools/python/
> python3-supervisor_4.2.4.bb b/meta-python/recipes-devtools/python/
> python3-supervisor_4.2.4.bb
> >> index fdd8a76cf..7da29e39b 100644
> >> --- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
> >> +++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
> >> @@ -13,6 +13,11 @@ PYPI_PACKAGE = "supervisor"
> >>   inherit pypi systemd setuptools3
> >>   RDEPENDS:${PN} = "\
> >>       ${PYTHON_PN}-meld3 \
> >> +    ${PYTHON_PN}-io \
> >> +    ${PYTHON_PN}-xmlrpc \
> >> +    ${PYTHON_PN}-resource \
> >> +    ${PYTHON_PN}-setuptools \
> >> +    ${PYTHON_PN}-smtpd \
> >>   "


FWIW, we don’t need to carry the ${PYTHON_PN} if the version no longer
supports python 2.

>
> >>
> >>   SRC_URI += "file://supervisord.conf \
> >> --
> >> 2.25.1
> >>
> >>
> >>
> >>
> >
> >
> > --
> > Jan Vermaete
> > “Success is a self-correcting phenomenom.” -- Gary Hamel
> >
> >
> >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97966):
> https://lists.openembedded.org/g/openembedded-devel/message/97966
> Mute This Topic: https://lists.openembedded.org/mt/92555239/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Martin Großhauser July 26, 2022, 1:51 p.m. UTC | #4
On 25.07.22 05:21, Tim Orling wrote:
>
>
> On Sun, Jul 24, 2022 at 7:01 PM Khem Raj <raj.khem@gmail.com <mailto:raj.khem@gmail.com>> wrote:
>
>     On Sun, Jul 24, 2022 at 3:31 PM Jan Vermaete <jan.vermaete@gmail.com <mailto:jan.vermaete@gmail.com>> wrote:
>      >
>      > Hi,
>      >
>      > Could it be it should be '${PYTHON_PN}-setuptools-native' iso  '${PYTHON_PN}-setuptools' ?
>
>     rdep on a native package wont be a good thing.
>      >
>      > Br
>      >
>      > On Fri, Jul 22, 2022 at 9:39 PM Martin Großhauser <mgrosshauser@gmx.net <mailto:mgrosshauser@gmx.net>> wrote:
>      >>
>      >> Running supervisord without these fails with import errors. smtpd might look strange, but provides required asynchat.py.
>      >> ---
>      >>   .../recipes-devtools/python/python3-supervisor_4.2.4.bb <http://python3-supervisor_4.2.4.bb>      | 5 +++++
>      >>   1 file changed, 5 insertions(+)
>      >>
>      >> diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb <http://python3-supervisor_4.2.4.bb> b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb <http://python3-supervisor_4.2.4.bb>
>      >> index fdd8a76cf..7da29e39b 100644
>      >> --- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb <http://python3-supervisor_4.2.4.bb>
>      >> +++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb <http://python3-supervisor_4.2.4.bb>
>      >> @@ -13,6 +13,11 @@ PYPI_PACKAGE = "supervisor"
>      >>   inherit pypi systemd setuptools3
>      >>   RDEPENDS:${PN} = "\
>      >>       ${PYTHON_PN}-meld3 \
>      >> +    ${PYTHON_PN}-io \
>      >> +    ${PYTHON_PN}-xmlrpc \
>      >> +    ${PYTHON_PN}-resource \
>      >> +    ${PYTHON_PN}-setuptools \
>      >> +    ${PYTHON_PN}-smtpd \
>      >>   "
>
>
> FWIW, we don’t need to carry the ${PYTHON_PN} if the version no longer supports python 2.

I submitted a revised patch (v2) fixing that.

>
>
>      >>
>      >>   SRC_URI += "file://supervisord.conf \
>      >> --
>      >> 2.25.1
>      >>
>      >>
>      >>
>      >>
>      >
>      >
>      > --
>      > Jan Vermaete
>      > “Success is a self-correcting phenomenom.” -- Gary Hamel
>      >
>      >
>      >
>
>
>
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97967): https://lists.openembedded.org/g/openembedded-devel/message/97967
> Mute This Topic: https://lists.openembedded.org/mt/92555239/7053818
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [mgrosshauser@gmx.net]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
index fdd8a76cf..7da29e39b 100644
--- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
+++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
@@ -13,6 +13,11 @@  PYPI_PACKAGE = "supervisor"
  inherit pypi systemd setuptools3
  RDEPENDS:${PN} = "\
      ${PYTHON_PN}-meld3 \
+    ${PYTHON_PN}-io \
+    ${PYTHON_PN}-xmlrpc \
+    ${PYTHON_PN}-resource \
+    ${PYTHON_PN}-setuptools \
+    ${PYTHON_PN}-smtpd \
  "

  SRC_URI += "file://supervisord.conf \