diff mbox series

[meta-security,V3] meta-security: Add recipe for libhoth

Message ID 20220722163510.2229149-1-jebr@google.com
State Accepted
Delegated to: Armin Kuster
Headers show
Series [meta-security,V3] meta-security: Add recipe for libhoth | expand

Commit Message

John Broadbent July 22, 2022, 4:35 p.m. UTC
From: John Edward Broadbent <jebr@google.com>

Libhoth is usb protocol implementation which is required for hoth class
devices

Signed-off-by: John Edward Broadbent <jebr@google.com>
---
 meta-tpm/recipes-tpm/hoth/libhoth_git.bb | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-tpm/recipes-tpm/hoth/libhoth_git.bb

Comments

Khem Raj July 22, 2022, 4:47 p.m. UTC | #1
On Fri, Jul 22, 2022 at 12:35 PM John Broadbent via
lists.yoctoproject.org <jebr=google.com@lists.yoctoproject.org> wrote:
>
> From: John Edward Broadbent <jebr@google.com>
>
> Libhoth is usb protocol implementation which is required for hoth class
> devices
>
> Signed-off-by: John Edward Broadbent <jebr@google.com>
> ---
>  meta-tpm/recipes-tpm/hoth/libhoth_git.bb | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-tpm/recipes-tpm/hoth/libhoth_git.bb
>
> diff --git a/meta-tpm/recipes-tpm/hoth/libhoth_git.bb b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> new file mode 100644
> index 0000000..a3ebce7
> --- /dev/null
> +++ b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Google Hoth USB library"
> +DESCRIPTION = "Libraries and example programs for interacting with a \
> +               hoth-class root of trust."
> +HOMEPAGE = "https://github.com/google/libhoth"
> +
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> +
> +SRC_URI = "git://github.com/google/libhoth;protocol=https;branch=main"
> +SRCREV = "1622e8a040d21dd564fdc1cb4df5eda01688c197"

it still has the musl related issue, that I pointed out

> +
> +DEPENDS += "libusb1"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit pkgconfig meson
> +
> --
> 2.37.1.359.gd136c6c3e2-goog
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> You automatically follow any topics you start or reply to.
> View/Reply Online (#57624): https://lists.yoctoproject.org/g/yocto/message/57624
> Mute This Topic: https://lists.yoctoproject.org/mt/92551443/1997914
> Group Owner: yocto+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
John Broadbent July 22, 2022, 5 p.m. UTC | #2
That is unexpected.

The sha change should have changed the PAGE_SIZE to SPI_PAGE_SIZE,
correcting the macro shadowing issue.
See:
https://github.com/google/libhoth/commit/1622e8a040d21dd564fdc1cb4df5eda01688c197

Thanks for very quick review
John Broadbent

On Fri, Jul 22, 2022 at 9:47 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Fri, Jul 22, 2022 at 12:35 PM John Broadbent via
> lists.yoctoproject.org <jebr=google.com@lists.yoctoproject.org> wrote:
> >
> > From: John Edward Broadbent <jebr@google.com>
> >
> > Libhoth is usb protocol implementation which is required for hoth class
> > devices
> >
> > Signed-off-by: John Edward Broadbent <jebr@google.com>
> > ---
> >  meta-tpm/recipes-tpm/hoth/libhoth_git.bb | 17 +++++++++++++++++
> >  1 file changed, 17 insertions(+)
> >  create mode 100644 meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> >
> > diff --git a/meta-tpm/recipes-tpm/hoth/libhoth_git.bb b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> > new file mode 100644
> > index 0000000..a3ebce7
> > --- /dev/null
> > +++ b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> > @@ -0,0 +1,17 @@
> > +SUMMARY = "Google Hoth USB library"
> > +DESCRIPTION = "Libraries and example programs for interacting with a \
> > +               hoth-class root of trust."
> > +HOMEPAGE = "https://github.com/google/libhoth"
> > +
> > +LICENSE = "Apache-2.0"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> > +
> > +SRC_URI = "git://github.com/google/libhoth;protocol=https;branch=main"
> > +SRCREV = "1622e8a040d21dd564fdc1cb4df5eda01688c197"
>
> it still has the musl related issue, that I pointed out
>
> > +
> > +DEPENDS += "libusb1"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +inherit pkgconfig meson
> > +
> > --
> > 2.37.1.359.gd136c6c3e2-goog
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > You automatically follow any topics you start or reply to.
> > View/Reply Online (#57624): https://lists.yoctoproject.org/g/yocto/message/57624
> > Mute This Topic: https://lists.yoctoproject.org/mt/92551443/1997914
> > Group Owner: yocto+owner@lists.yoctoproject.org
> > Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Khem Raj July 22, 2022, 5:13 p.m. UTC | #3
On Fri, Jul 22, 2022 at 1:00 PM John Broadbent <jebr@google.com> wrote:
>
> That is unexpected.
>
> The sha change should have changed the PAGE_SIZE to SPI_PAGE_SIZE,
> correcting the macro shadowing issue.
> See:
> https://github.com/google/libhoth/commit/1622e8a040d21dd564fdc1cb4df5eda01688c197
>

right, I missed that in this v3 the SRCREV is bumped too which should
address the issue.


> Thanks for very quick review
> John Broadbent
>
> On Fri, Jul 22, 2022 at 9:47 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > On Fri, Jul 22, 2022 at 12:35 PM John Broadbent via
> > lists.yoctoproject.org <jebr=google.com@lists.yoctoproject.org> wrote:
> > >
> > > From: John Edward Broadbent <jebr@google.com>
> > >
> > > Libhoth is usb protocol implementation which is required for hoth class
> > > devices
> > >
> > > Signed-off-by: John Edward Broadbent <jebr@google.com>
> > > ---
> > >  meta-tpm/recipes-tpm/hoth/libhoth_git.bb | 17 +++++++++++++++++
> > >  1 file changed, 17 insertions(+)
> > >  create mode 100644 meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> > >
> > > diff --git a/meta-tpm/recipes-tpm/hoth/libhoth_git.bb b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> > > new file mode 100644
> > > index 0000000..a3ebce7
> > > --- /dev/null
> > > +++ b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> > > @@ -0,0 +1,17 @@
> > > +SUMMARY = "Google Hoth USB library"
> > > +DESCRIPTION = "Libraries and example programs for interacting with a \
> > > +               hoth-class root of trust."
> > > +HOMEPAGE = "https://github.com/google/libhoth"
> > > +
> > > +LICENSE = "Apache-2.0"
> > > +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> > > +
> > > +SRC_URI = "git://github.com/google/libhoth;protocol=https;branch=main"
> > > +SRCREV = "1622e8a040d21dd564fdc1cb4df5eda01688c197"
> >
> > it still has the musl related issue, that I pointed out
> >
> > > +
> > > +DEPENDS += "libusb1"
> > > +
> > > +S = "${WORKDIR}/git"
> > > +
> > > +inherit pkgconfig meson
> > > +
> > > --
> > > 2.37.1.359.gd136c6c3e2-goog
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > You automatically follow any topics you start or reply to.
> > > View/Reply Online (#57624): https://lists.yoctoproject.org/g/yocto/message/57624
> > > Mute This Topic: https://lists.yoctoproject.org/mt/92551443/1997914
> > > Group Owner: yocto+owner@lists.yoctoproject.org
> > > Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
akuster808 July 30, 2022, 9:14 p.m. UTC | #4
merged.

On 7/22/22 09:35, John Broadbent via lists.yoctoproject.org wrote:
> From: John Edward Broadbent <jebr@google.com>
>
> Libhoth is usb protocol implementation which is required for hoth class
> devices
>
> Signed-off-by: John Edward Broadbent <jebr@google.com>
> ---
>   meta-tpm/recipes-tpm/hoth/libhoth_git.bb | 17 +++++++++++++++++
>   1 file changed, 17 insertions(+)
>   create mode 100644 meta-tpm/recipes-tpm/hoth/libhoth_git.bb
>
> diff --git a/meta-tpm/recipes-tpm/hoth/libhoth_git.bb b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> new file mode 100644
> index 0000000..a3ebce7
> --- /dev/null
> +++ b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Google Hoth USB library"
> +DESCRIPTION = "Libraries and example programs for interacting with a \
> +               hoth-class root of trust."
> +HOMEPAGE = "https://github.com/google/libhoth"
> +
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> +
> +SRC_URI = "git://github.com/google/libhoth;protocol=https;branch=main"
> +SRCREV = "1622e8a040d21dd564fdc1cb4df5eda01688c197"
> +
> +DEPENDS += "libusb1"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit pkgconfig meson
> +
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#57624): https://lists.yoctoproject.org/g/yocto/message/57624
> Mute This Topic: https://lists.yoctoproject.org/mt/92551443/3616698
> Group Owner: yocto+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-tpm/recipes-tpm/hoth/libhoth_git.bb b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
new file mode 100644
index 0000000..a3ebce7
--- /dev/null
+++ b/meta-tpm/recipes-tpm/hoth/libhoth_git.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Google Hoth USB library"
+DESCRIPTION = "Libraries and example programs for interacting with a \
+               hoth-class root of trust."
+HOMEPAGE = "https://github.com/google/libhoth"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://github.com/google/libhoth;protocol=https;branch=main"
+SRCREV = "1622e8a040d21dd564fdc1cb4df5eda01688c197"
+
+DEPENDS += "libusb1"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig meson
+