diff mbox series

[meta-python] python3-alembic: upgrade 1.8.0 -> 1.8.1

Message ID 1658453712-23978-1-git-send-email-zhengrq.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-alembic: upgrade 1.8.0 -> 1.8.1 | expand

Commit Message

zhengrq.fnst@fujitsu.com July 22, 2022, 1:35 a.m. UTC
Changelog:
==========
[bug] [sqlite]
--------------
Fixed bug where the SQLite implementation of Operations.rename_table() would
render an explicit schema name for both the old and new table name, which while
is the standard ALTER syntax, is not accepted by SQLite’s syntax which doesn’t
support a rename across schemas. In particular, the syntax issue would prevent
batch mode from working for SQLite databases that made use of attached databases
(which are treated as “schemas” in SQLAlchemy).

[bug] [batch]
-------------
Added an error raise for the condition where Operations.batch_alter_table() is
used in --sql mode, where the operation requires table reflection, as is the
case when running against SQLite without giving it a fixed Table object.
Previously the operation would fail with an internal error. To get a
“move and copy” batch operation as a SQL script without connecting to a
database, a Table object should be passed to the
Operations.batch_alter_table.copy_from parameter so that reflection may be
skipped.

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
---
 .../{python3-alembic_1.8.0.bb => python3-alembic_1.8.1.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-alembic_1.8.0.bb => python3-alembic_1.8.1.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.8.0.bb b/meta-python/recipes-devtools/python/python3-alembic_1.8.1.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-alembic_1.8.0.bb
rename to meta-python/recipes-devtools/python/python3-alembic_1.8.1.bb
index 3b12439cbc..3e31158835 100644
--- a/meta-python/recipes-devtools/python/python3-alembic_1.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.8.1.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=f5a8522010db1a393833988dbe2c7f0b"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "a2d4d90da70b30e70352cd9455e35873a255a31402a438fe24815758d7a0e5e1"
+SRC_URI[sha256sum] = "cd0b5e45b14b706426b833f06369b9a6d5ee03f826ec3238723ce8caaf6e5ffa"
 
 PYPI_PACKAGE = "alembic"