Patchwork [CONSOLIDATED,PULL,10/27] qemu: change default kernel to 3.0.x

login
register
mail settings
Submitter Saul Wold
Date Aug. 17, 2011, 6:26 a.m.
Message ID <14831b6ba26a6e43a1771a8516d0af145006c504.1313560883.git.sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/10035/
State New, archived
Headers show

Comments

Saul Wold - Aug. 17, 2011, 6:26 a.m.
From: Bruce Ashfield <bruce.ashfield@windriver.com>

The explicit setting of version preference to 2.6.37 is
no longer required. All of the qemu targets have been built
and boot tested on 3.0.1 for core-image-minimal and core-image-sato
and are safe for wider build/boot testing.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
---
 meta/conf/machine/include/qemu.inc |    1 -
 1 files changed, 0 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/conf/machine/include/qemu.inc b/meta/conf/machine/include/qemu.inc
index 4cab6f3..9ef242f 100644
--- a/meta/conf/machine/include/qemu.inc
+++ b/meta/conf/machine/include/qemu.inc
@@ -12,7 +12,6 @@  RDEPENDS_kernel-base = ""
 
 # Use a common kernel recipe for all QEMU machines
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
-PREFERRED_VERSION_linux-yocto ?= "2.6.37+git%"
 #PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
 
 EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native"